PHP is amongst the most widely used open-source server-side programming languages. It is rather popular because it’s free software, which can be used to build responsive sites such as social networking websites, online stores or online learning websites rather than static HTML websites. A PHP module should be present on the web server where a PHP site is hosted so that its source code can be ‘decrypted’. As there are no license charges for this type of module and the language itself offers infinite options for the web applications that you set up, there’re hundreds of millions of PHP websites. On top of that, there’re many PHP scripts, which you can use for your websites without needing to have any coding know-how. Considering the fact that there’re a few PHP versions, you ought to ensure that the very same version that you used while developing your site is installed on the server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

With our Linux cloud hosting, you will be able to select the version of PHP that will be active for your web hosting account, as multiple versions are available on our servers. With as little as one click of the mouse, you will be able to switch between PHP 4, 5, 7 and whenever a new version is published in the future, we will include it in the Hepsia Control Panel without removing the previous versions. In this way, you will be able to host all the websites that you’ve built over the years. In contrast with lots of other web hosting suppliers, we won’t force you to update such sites, as a script may be out of date, but this doesn’t necessarily mean that it is vulnerable as you may have carried out modifications to its source code to patch safety breaches. For your convenience, you will even be able to specify a different version of PHP for each individual site hosted in your hosting account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you’ve got a website built on an earlier PHP version and you have poured time and efforts into setting it up, patching security loopholes and inserting web content, you’ll need to find a hosting service that can support it, since almost all web hosting vendors today offer only the latest PHP version and abandon the older ones. We, however, have decided to permit you to choose the version that your very own sites need. Our Linux semi-dedicated hosting support PHP 4, PHP 5 and PHP 7, so you’ll be able to use both older and newer scripts without losing any custom modifications or frittering away time and efforts trying to make your sites compatible with the hosting environment. You can change the version through the Hepsia Control Panel and such an update will apply to the whole semi-dedicated account, but you will also have the ability to specify a different version for each site that you host in your account using an .htaccess file.